2. Instalar nuevo proyecto

En este capítulo, se aprenderá a configurar el entorno de desarrollo para crear una nueva aplicación de chat utilizando Laravel y Laravel Web Socket. Se explicará cómo instalar las herramientas necesarias y cómo crear un nuevo proyecto de Laravel.

Vite: https://youtu.be/4gxxWTe3pVA 


4 comentarios

Inicia sesión para comentar

Comentarios:

  • José Daniel Mejias

    José Daniel Mejias hace 3 meses

    Hola, este curso funciona tambien para Laravel en su version 10?

  • Fabián Suárez

    Fabián Suárez hace 1 año

    Se puede instalar boostrap con jestrap como con laravel 8? e intentando y no me funciona..quisera confirma si funciona o no o talvez me este faltando algo.!..Gracias

    • Victor Arana Flores hace 1 año

      Hola Fabian, me parece que ya te respondí en el grupo Coders Free.

      Se puede, pero tienes que dejar de usar Vite, y migrarlo a Larave mix. Ya que Jestrap es un paquete echo para web pack

  • Sergio Ariel A. Mondino

    Sergio Ariel A. Mondino hace 2 años

    Hola, Laravel 9 ahora, genera los proyectos con Vite, no usa más Webpack, por lo tanto, no puedo correr lo siguiente:

     

    npm run watch

     

    Dá ERRORES,  pero si puedo usar

    npm run dev ?????

     

    El Segundo tema, es que en el app.blade.php,  tengo esto

            <!-- Styles -->

            @livewireStyles


     

            <!-- Scripts -->

            @vite(['resources/css/app.css', 'resources/js/app.js'])

     

    No están más las directivas de mix('ccs/app.css').etc,etc. de Webpack

     

    Podes comentar como afrontamos el Cambio?. Muchas Gracias!!!

    • Victor Arana Flores hace 1 año

      Hola Sergio, simplemente ha cambiado el compilador con el que trabaja Laravel, y en nada afecta nuestra forma de programar, ya que nosotros trabajamos con los archivos compilados.

      Para compilar ejecuta npm run dev, y no cambies nada en tu archivo app.blade.php ya que el @vite lo que hace es referencia de Vite que es el nuevo compilador

    • Gabriel De La Fuente Garcia hace 1 año

      Hola Victor, recientemente he cogido este curso que me parece super interesante e importante. Yo tengo el mismo problema pero con npm run dev, me da error el vite. el problema es que no me puede coger los estilos para las plantillas. 

       

      Darte la enhorabuena y felicitarte por tus cursos.

    • Victor Arana Flores hace 1 año

      Hola Gabriel, npm run dev inicia el compilador de vite. Asegurate de trabajar con alguno de los dominios que te genera el compilador de vite.

      Por ejempo codersfree.test o 127.0.0.1:5173

    • Gabriel De La Fuente Garcia hace 1 año

      Hola Victor, encontré el error. Al parecer hay que tener la ultima version de Node.js instalada en el sistema. Muchas gracias makina!!! Enhorabuena por tus cursos. Soy fan!!

    • Victor Arana Flores hace 1 año

      Que bueno que lo solucionaste Gabriel.

  • Kerlis Lozano

    Kerlis Lozano hace 2 años

    funciona con laravel 8?