2. Preparación del entorno de desarrollo

En este módulo, aprenderás acerca de los programas necesarios para poder desarrollar un proyecto de ecommerce con Laravel, Livewire, Tailwind y Alpine. Desde la instalación del entorno de desarrollo, hasta la configuración de las herramientas necesarias.


Xampp: https://www.apachefriends.org/download.html

Composer: https://getcomposer.org/ 

Visual Studio Code: https://code.visualstudio.com/ 

Git: https://git-scm.com/ 

MySQL Workbench: https://dev.mysql.com/downloads/workbench/ 


11 comentarios

Inicia sesión para comentar

Comentarios:

  • Brayan Miguel Oblitas Mejia

    Brayan Miguel Oblitas Mejia hace 9 meses

    hola, tengo una duda, quiero trabajar con laravel 10 y php 8, este curso se puede acolplar a esas caracterisicas, o necesariamente tengo que trabajar con laravel 8?

    • Victor Arana Flores hace 9 meses

      Puedes hacerlo con laravel 5.5 si deseas, y cualqier version posterior a esta.

  • Juan Carlos Huallpa

    Juan Carlos Huallpa hace 1 año

    Buenas Victor, el ecomerce en version Laravel 9 y PHP 8 se puede integrar con Cybersources?, tengo inconvenientes con la integración  , y los paquetes de terceros quedaron sin mantenimiento para esta versión. si me puedes aclarar cual seria el mejor método o si ya realizaste ese tipo de integraciones. quedo agradecido un abrazo cordial. 

    • Victor Arana Flores hace 1 año

      Hola Juan Carlos ¿Que paquete de tercero a quedado sin mantenimiento?

  • Nicolás

    Nicolás hace 1 año

    Buenas Víctor, ¿este curso se puede hacer con Laravel 9? Me refiero a que no habría eventuales problemas a la hora de usar PHP 8 en adelante e integrar Mercado Pago, es posible?

    • Victor Arana Flores hace 1 año

      Hola Nicolas, primero que nada disculpa por la demora en la respuesta. Estas dos semanas han sido de mucho trabajo para mi y no podía darme el tiempo para responder.

      Comentarte que el checkout de Mercado Pago ya acepta trabajar con PHP 8.1 :D

    • Gustavo hace 1 año

      xd

    • Gustavo hace 1 año

      xd

  • Elias Alberto Alegre Barazorda

    Elias Alberto Alegre Barazorda hace 1 año

    profesor acabo de comprar el curso y en la pagina de descarga ya no me sale la version de php 7.4 sino la 8 sera que puedo usar esa version o debo buscar la version 7.4 forzosamente ?

    • Victor Arana Flores hace 1 año

      Hola Elias. Si quieres trabajar con la ultima versión de laravel tienes que instalar php 8.1 o superior. Recuerda tambien que este no es un curso básico de Laravel.

       

      Si es la primera vez que trabajas con Laravel te recomendaria que veas mi curso de laravel desde cero, ya sea el gratuito o el de paga (mucho más completo)

  • Francisco Alvarez Higuita

    Francisco Alvarez Higuita hace 1 año

    Hola Víctor una pregunta: para una carga masiva a través de un archivo de Excel de que formas podría hacerse ? 

    • Victor Arana Flores hace 1 año

      Hola Francisco. Puedes llevar mi curso de Laravel Excel. Ahi enseño como hacerlo.

  • Daniel

    Daniel hace 1 año

    Hola Victor una pregunta seguire el curso con una instalacion de Laravel 9, hay algun problema o cambio critico de esta version vs la 8. Mi pregunta también es si se pudiera implementar de manera correcta la  pasarela de Mercado Pago con la version 9 

    • Victor Arana Flores hace 1 año

      Hola Daniel, la unica diferencia si instalas Laravel 9 es que ahora esta trabaja con Vite, y por tanto  vas a tener que dejar corriendo npm run dev mientras estes en desarrollo.

      Te comparto este video para que puedas revisarlo.

       

      En cuanto a Mercado Pago, nada tiene que ver con la versión de Laravel que uses, sino con la version de PHP que tengas instalado. Pero si, ya puedes instalar los sdk de Mercado Pago con las ultimas versiones de PHP

    • Daniel hace 1 año

      Muchas gracias Victor!!

    • Jose Alejandro Sanchez hace 1 año

      acabe de comprar este curso tengo experiencia con laravel 7, 8, 9(pero no con livewire), y quiero intentarlo hacer con laravel 10 ?, vi este video claro y  lo de Vite que es importante, pero hay alguna otra cosa que me frene ?

    • Victor Arana Flores hace 1 año

      Hola Jose, si sabes Blade, ya tienes el 80% de Livewire.

      Fue la razon por la que mis cursos lo hago con Livewire y no con otra tecnología javascript.

  • Antonio Márquez

    Antonio Márquez hace 1 año

    Hola Victor. Me gustaría saber si el código de este curso está disponible y, si la respuesta es afirmativa, dónde lo puedo encontrar.

    Gracias

    • Victor Arana Flores hace 1 año

      Hola Antonio, te comparto el link 

      https://github.com/coders-free/ecommerce 

    • Edmer hace 1 año

      Profe, los archivos del proyecto en dicho repositorio es parcial, tiene algún completo?

  • Xavier Montalvo

    Xavier Montalvo hace 1 año

    Hola Victor, crees que pueda implementar MercadoPago para hacer tanto ventas como cobros en Ecuador? Tengo entendido que en Ecuador ya lanzaron oficialmente hace poco MercadoPago pero no se si pueda utilizar el SDK

    • Victor Arana Flores hace 1 año

      Hola Xavier. Si Mecado Pago está presente en Ecuador, la forma de implementarlo es exactamente la misma que en otros paises :D

  • Code

    Code hace 2 años

    Hola, deberías considerar la opción para que en el reproductor se pueda seleccionar manualmente la resolución del video. 

    • Victor Arana Flores hace 2 años

      Hola Code, trataré de implementar  esa funcionalidad en el transcurso de las proximas semanas.

  • Victor Herrera

    Victor Herrera hace 2 años

    hola amigo victor apenas voy a  empezar coneste curso, queria preguntarte lode mercado pago y php ya tiene un año que realisaste el curso, que actualizacion le podriamos implentar????

    • Victor Arana Flores hace 2 años

      Hola Victor ¿A qué te refieres con que actualización?