Renombrar columnas
Comprar curso

62. Renombrar columnas


1 comentarios

Inicia sesión para comentar

Comentarios:

  • Juan Montoya Vega

    Juan Montoya Vega hace 2 meses

    Hola intenté instalar ese paquete y me sale este error (estoy usando laravel 10) ya intenté poner las sugerencias que me muestra pero aun asi no da. Gracias de antemano.

    Problem 1
       - doctrine/common[v2.4.0, ..., v2.5.3] require doctrine/inflector 1.* -> found doctrine/inflector[v1.0, ..., 1.4.4] but the package is fixed to 2.0.8 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
       - doctrine/common[v2.6.0, ..., v2.6.2] require php ~5.5|~7.0 -> your php version (8.2.4) does not satisfy that requirement.
       - doctrine/common[v2.7.0, ..., v2.7.3] require php ~5.6|~7.0 -> your php version (8.2.4) does not satisfy that requirement.
       - doctrine/common[v2.8.0, ..., v2.8.1] require php ~7.1 -> your php version (8.2.4) does not satisfy that requirement.
       - doctrine/common[v2.9.0, ..., 2.13.0] require php ^7.1 -> your php version (8.2.4) does not satisfy that requirement.
       - doctrine/dbal[v2.6.0, ..., v2.9.3] require php ^7.1 -> your php version (8.2.4) does not satisfy that requirement.
       - doctrine/common[2.13.1, ..., 2.13.3] require doctrine/inflector ^1.0 -> found doctrine/inflector[v1.0, ..., 1.4.4] but the package is fixed to 2.0.8 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
       - doctrine/dbal[v2.10.0, ..., 2.10.4] require php ^7.2 -> your php version (8.2.4) does not satisfy that requirement.
       - doctrine/dbal[2.11.0, ..., 2.11.3] require php ^7.3 -> your php version (8.2.4) does not satisfy that requirement.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.7.2.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.4.6.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.3.8.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.3.5.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.2.2.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.1.5.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.1.0.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 3.0.0.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.13.9.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.13.8.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.13.1.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.12.1.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.3.5.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.3.2.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.2.2.
       - carbonphp/carbon-doctrine-types 3.1.0 conflicts with doctrine/dbal 2.1.7.
       - nesbot/carbon 2.72.1 requires carbonphp/carbon-doctrine-types * -> satisfiable by carbonphp/carbon-doctrine-types[3.1.0].
       - laravel/framework v10.37.3 requires nesbot/carbon ^2.67 -> satisfiable by nesbot/carbon[2.72.1].
       - doctrine/dbal[v2.5.0, ..., v2.5.2] require doctrine/common >=2.4,<2.6-dev -> satisfiable by doctrine/common[v2.4.0, ..., v2.5.3].
       - doctrine/dbal[v2.5.3, ..., v2.5.5] require doctrine/common >=2.4,<2.7-dev -> satisfiable by doctrine/common[v2.4.0, ..., v2.6.2].
       - doctrine/dbal[v2.5.6, ..., v2.5.13] require doctrine/common >=2.4,<2.8-dev -> satisfiable by doctrine/common[v2.4.0, ..., v2.7.3].
       - doctrine/dbal[v2.4.0, ..., v2.4.5] require doctrine/common ~2.4 -> satisfiable by doctrine/common[v2.4.0, ..., 2.13.3].
       - laravel/framework is locked to version v10.37.3 and an update of this package was not requested.
       - Root composer.json requires doctrine/dbal * -> satisfiable by doctrine/dbal[2.1.5, ..., 2.13.9, 3.0.0, ..., 3.7.2].

    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
    You can also try re-running composer require with an explicit version constraint, e.g. "composer require doctrine/dbal:*" to figure out if any version is installable, or "composer require doctrine/dbal:^2.1" if you know which you need.

    Installation failed, reverting ./composer.json and ./composer.lock to their original content.

    • Victor Arana Flores hace 2 meses

      Hola amigo, en primer lugar veo que instalaste la aplicacion inicialmente con una version de PHP 7.3 y luego lo pasaste a una versión de PHP 8.2.

      Dato curioso es que veo que dice que tienes una version de laravel 10, lo cual es imposible con una versión de PHP 7.3 ya que Laravel 10 requiere minimo una version de PHP 8.1, lo que me da entender que has intentado actualizar la versión de Laravel.

      Te sugiero que leas con detenimiento la guia de actualizacion, y que tambien compruebes que los paquetes que tienes instalado sean compatibles con Laravel 10.

      Por lo pronto lo que te diría que hagas es que te dirijas a tu archivo composer.json y actualices esta informacion: "php": “^8.2” (que es aparentemente la versión con la que estas trabajando) luego de eso ejecuta composer update para que todos los paquetes se actualices y sea compatibles con esa versión de PHP.

      Mas allá de eso lamentablemente no podría ayudarte, ya que tendría que revisar tu proyecto para ver como está estructurado.

    • Juan Montoya Vega hace 2 meses

      Hola, gracias por responder, en realidad no he tenido el 7.3, instale el xampp y venia con el 8.2, y bajo eso instalé laravel 10, es un poco raro pero lo arreglé agregando esto en el require del composer.json : 

      "doctrine/dbal": “*” 

      y cuando le di composer update, se instaló correctamente :D